Z3MCoupe.com Forums

Go Back   Z3MCoupe.com Forums > M Coupť Technical > Technical Discussion
HOME Gallery Register Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 01-08-2020, 06:07 PM
Howiez Howiez is offline
Senior Member
 
Join Date: Jun 2007
Posts: 450
Default Brake lights not working

Luckily someone noticed today: all the brake lights no longer work. Just wondering, is there a switch operating off the hydraulics that may when broken, cause the brake electrics to fail? Anyone else encountered this?
Thanks
__________________
S54 M Coupe
D5 Alpina Touring
Reply With Quote
  #2  
Old 01-08-2020, 06:30 PM
Hatter Hatter is offline
Senior Member
 
Join Date: May 2007
Posts: 195
Default

There's a switch under the brake pedal that can go bad. Relatively cheap and easy diy (bit fiddly, but that's about it).
__________________
2001 S54 Silver with Red/Black interior. Totally standard.
Reply With Quote
  #3  
Old 01-08-2020, 06:56 PM
Howiez Howiez is offline
Senior Member
 
Join Date: Jun 2007
Posts: 450
Default

Thanks. Assume itís a part available via dealers?
__________________
S54 M Coupe
D5 Alpina Touring
Reply With Quote
  #4  
Old 02-08-2020, 11:58 AM
Hatter Hatter is offline
Senior Member
 
Join Date: May 2007
Posts: 195
Default

I think this is the part number: 61318360417

Readily available through dealers / parts suppliers.
__________________
2001 S54 Silver with Red/Black interior. Totally standard.
Reply With Quote
  #5  
Old 02-08-2020, 12:09 PM
Howiez Howiez is offline
Senior Member
 
Join Date: Jun 2007
Posts: 450
Default

Very helpful thanks.
Iíll do that then think about the cruise control which has also stopped working!
__________________
S54 M Coupe
D5 Alpina Touring
Reply With Quote
  #6  
Old 02-08-2020, 01:13 PM
Andy M Coupe Andy M Coupe is offline
Junior Member
 
Join Date: Jul 2020
Posts: 7
Default

You may find the cruise starts to work again when you get the brake lights working. The cruise monitors the brake switch and uses it to cancel the cruise when you press the brake pedal so if faulty it maybe sending the cancel signal all the time. It would also be worth checking the connector for the switch is firmly attached!

Andy
Reply With Quote
  #7  
Old 02-08-2020, 02:01 PM
Howiez Howiez is offline
Senior Member
 
Join Date: Jun 2007
Posts: 450
Default

Yes good point! Thanks
__________________
S54 M Coupe
D5 Alpina Touring
Reply With Quote
  #8  
Old 05-08-2020, 05:23 AM
iamalexm iamalexm is offline
Junior Member
 
Join Date: Jul 2020
Posts: 11
Default

Make sure to keep us posted one you resolve the issue.
Reply With Quote
  #9  
Old 15-08-2020, 07:24 PM
Howiez Howiez is offline
Senior Member
 
Join Date: Jun 2007
Posts: 450
Default

Great advice from this forum. All fixed !! Plus the cruise now works, so please bear in mind if anyone else has cruise control issues, it may be the brake light switch.
It wasnít the easiest of jobs, but would be straight forward if I did it again. Just need to remember to leave the red surround pulled out when youíre fitting the switch, otherwise itís a real struggle.
Thanks again.
Any ideas about power steering! Mine has always made a whining noise and is slow unless I increase the Revs when stationary. Iíve changed the rusty piping around the rad plus changed the power steering fluid but it still isnít quite right, unless itís generally poor on these cars, problem is Iíve never driven another one do have nothing to compare it with.
__________________
S54 M Coupe
D5 Alpina Touring
Reply With Quote
  #10  
Old 16-08-2020, 09:00 PM
Ian_C's Avatar
Ian_C Ian_C is offline
Senior Member
 
Join Date: Dec 2011
Location: Lytham St Annes
Posts: 900
Default

Quote:
Originally Posted by Howiez View Post
Great advice from this forum. All fixed !! Plus the cruise now works, so please bear in mind if anyone else has cruise control issues, it may be the brake light switch.
It wasnít the easiest of jobs, but would be straight forward if I did it again. Just need to remember to leave the red surround pulled out when youíre fitting the switch, otherwise itís a real struggle.
Thanks again.
Any ideas about power steering! Mine has always made a whining noise and is slow unless I increase the Revs when stationary. Iíve changed the rusty piping around the rad plus changed the power steering fluid but it still isnít quite right, unless itís generally poor on these cars, problem is Iíve never driven another one do have nothing to compare it with.
Did you bleed the air out when you changed the fluid? (Lock to lock a couple of times with the cap off the power steering fluid reservoir and the engine running)
__________________
1998 ///M Coupe

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:17 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.