Z3MCoupe.com Forums

Go Back   Z3MCoupe.com Forums > M Coupé Technical > Technical Discussion
HOME Gallery Register Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 26-07-2017, 11:03 AM
V1-Rotate's Avatar
V1-Rotate V1-Rotate is offline
Senior Member
 
Join Date: Apr 2015
Location: England
Posts: 173
Default Car won't start :(

Hi,

Thank you for any help that may be given.

I've got to the car after it not being started for a month and it won't start at all. The engine turns, there's power to the battery, I even put a booster pack on it. However the engine is simply turning and not firing up. It did start up for a split second and then died out. Needle showing half tank fuel which was correct.

Is there any fuse or shut off switch?

Thanks
Reply With Quote
  #2  
Old 26-07-2017, 11:06 AM
V1-Rotate's Avatar
V1-Rotate V1-Rotate is offline
Senior Member
 
Join Date: Apr 2015
Location: England
Posts: 173
Default

Car is a 2002 S54 M Coupe.

Thank you.
Reply With Quote
  #3  
Old 26-07-2017, 11:47 AM
Ian_C's Avatar
Ian_C Ian_C is offline
Senior Member
 
Join Date: Dec 2011
Location: Lytham St Annes
Posts: 661
Default

Possibly immobiliser? Have you tried your 2nd key?
__________________
1998 ///M Coupe

Reply With Quote
  #4  
Old 26-07-2017, 01:51 PM
V1-Rotate's Avatar
V1-Rotate V1-Rotate is offline
Senior Member
 
Join Date: Apr 2015
Location: England
Posts: 173
Default

Just the one key :/
Reply With Quote
  #5  
Old 26-07-2017, 02:30 PM
c_w's Avatar
c_w c_w is offline
Moderator
 
Join Date: Aug 2005
Location: North West
Posts: 8,434
Default

Does the fuel pump prime for a few seconds on ignition on?
Reply With Quote
  #6  
Old 26-07-2017, 03:41 PM
Walk Walk is offline
Senior Member
 
Join Date: Jan 2015
Posts: 137
Default

If the battery has been off or flat there's a chance the engine control unit has lost its sync with the immobiliser control unit.

You need to check the fault memory to see if any faults are stored.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:38 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.